Back

Ubuntu 15.10 Gromacs GPU加速错误解决办法

今天把新电脑装了Ubuntu15.10,装GPU加速版本,但是在gromacs安装的时候出现了问题,在cmake那一步就出错,make时也报错,make check直接显示找不到文件。

看错误日志发现CUDA的字眼,猜测是CUDA驱动版本是15.04的缘故,在网上搜,发现了相关教程。贴图如下:

按照先前安装教程安装

1.终端输入如下:

1
 **nvcc -V**(注意大写V)

应该有类似输出:

1
2
3
4
nvcc: NVIDIA(R) Cuda compiler driver
copyright (c) 2005-2015 NVIDIA Corporation
Built on ………………
Cuda compilation tools, release 7.5, V7.5.17

2.使用自带的samples进行GPU运算测试。

进入到cuda-7.5的samples目录,一般都是cd /usr/local/cuda-7.5/samples,然后会有一个Makefile文件,执行命令sudo make,不出意外地话,会出现带有红颜色的error错误,大概是这样的:unsupported GNU version! gcc versions later than 4.9 are not supported! 意思也很明显了,就是gcc的版本高于4.9,Cuda不支持。解释一下:ubuntu15.10自带的gcc是5.2.1,可以通过gcc –version(两个-)查看,但是cuda不支持超过4.9.0的gcc编译器。要么安装一个低版本的编译器,要么把cuda的这个限制给去掉。我选择的是后者,而且尚未出现其他问题。

3.解决方案如下:

1
2
3
4
    sudo cd /usr/local/cuda/include/ #进入到头文件目录cuda(而不是cuda-7.5);
    sudo cp host_config.h host_config.h.bak #备份原头文件;
    sudo gedit host_config.h #编辑头文件;
    ctrl+F查找4.9出现的地方,大约位于115行,在第113行处应该显示if _GNUC_>4 || (_GNUC_ == 4 && _GNUC_MINOR_ > 9),因为我们的是5.2.1,因此,把上面的2个4都改成5就ok了,保存退出。

自此解决,若还不放心,可以从新运行第2步的sudo make(注意目录同第二步)

参考文献:Ubuntu15.10_64位安装Theano+cuda7.5详细笔记

Licensed under CC BY-NC-SA 4.0